summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-01 10:41:29 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-01 10:41:29 +0000
commit846a4af8932138bf4c35f8f24ca1fc3e4ad1c86a (patch)
tree43c29cfec54d8fb65c46dc854bd5755141633be1 /cpukit/score/Makefile.am
parent2005-01-01 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-846a4af8932138bf4c35f8f24ca1fc3e4ad1c86a.tar.bz2
2005-01-01 Ralf Corsepius <ralf.corsepius@rtems.org>
* automake/compile.am, httpd/Makefile.am, itron/Makefile.am, libblock/Makefile.am, libcsupport/Makefile.am, libfs/Makefile.am, libmisc/Makefile.am, libnetworking/Makefile.am, librpc/Makefile.am, posix/Makefile.am, rtems/Makefile.am, sapi/Makefile.am, score/Makefile.am, wrapup/Makefile.am: Remove build-variant support.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 3188f22f9d..c684e01920 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -146,19 +146,13 @@ endif
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-EXTRA_LIBRARIES = libscore.a
-CLEANFILES = libscore.a
+noinst_LIBRARIES = libscore.a
libscore_a_SOURCES = $(C_FILES)
libscore_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-EXTRA_LIBRARIES += libscore_g.a
-CLEANFILES += libscore_g.a
-libscore_g_a_SOURCES = $(libscore_a_SOURCES)
-libscore_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-
EXTRA_DIST += $(STD_C_FILES) $(MP_C_FILES) src/Unlimited.txt
-all-local: $(PREINSTALL_FILES) libscore$(LIB_VARIANT).a
+all-local: $(PREINSTALL_FILES)
DISTCLEANFILES = include/rtems/score/cpuopts.h
@@ -484,7 +478,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/threadmp.inl
endif
endif
-CLEANFILES += $(PREINSTALL_FILES)
+CLEANFILES = $(PREINSTALL_FILES)
DISTCLEANFILES += $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/subdirs.am