summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorAndreas Heinig <andreas.heinig@cs.tu-dortmund.de>2012-08-06 13:46:27 -0400
committerGedare Bloom <gedare@rtems.org>2012-08-06 13:46:27 -0400
commit7a9288fe3524236c18ad64b73ce5fa0c6da484b0 (patch)
treea4d45344341f44c8e4529fa806114ac0df8af8ee /cpukit/score/Makefile.am
parentRemove generated files. (diff)
downloadrtems-7a9288fe3524236c18ad64b73ce5fa0c6da484b0.tar.bz2
PR2069: [CBS Scheduler] Memory leak and enqueue problem
Due to the fact that CBS extends the EDF scheduler, most parts of EDF are reused. One part is the allocation of the per-thread data. However, the CBS per-thread structure defines a further element (while including the rest of Scheduler_EDF_Per_thread)
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index cb512e41ad..6f9f94f3bf 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -238,6 +238,7 @@ libscore_a_SOURCES += src/scheduleredf.c \
## SCHEDULERCBS_C_FILES
libscore_a_SOURCES += src/schedulercbs.c \
+ src/schedulercbsallocate.c \
src/schedulercbsattachthread.c \
src/schedulercbscleanup.c \
src/schedulercbscreateserver.c \