summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-10-26 19:44:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-10-26 19:44:10 +0000
commit78dabb697cef81e6b77826c940d559fa49026a6d (patch)
treecabd3e3ee30209b1e48cb788ecb4f05441477c26 /cpukit/score/Makefile.am
parent2007-10-26 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-78dabb697cef81e6b77826c940d559fa49026a6d.tar.bz2
2007-10-26 Joel Sherrill <joel.sherrill@OARcorp.com>
* score/Makefile.am, score/include/rtems/score/thread.h, score/inline/rtems/score/thread.inl: No longer inline _Thread_Get. It resulted in unnessary code explosion, many uncovered paths when looking at binary executable coverage, and only optimized getting self. Id translations were still getting pushed to a subroutine call to _Objects_Get. Later the non-inlined version can be further optimized to get Ids in range for the current API, then self, then look at other APIs. * score/src/threadget.c: New file.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index ad3c68e87e..cdf975ea5c 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -126,7 +126,7 @@ libscore_a_SOURCES += src/pheapallocatealigned.c src/pheapallocate.c \
libscore_a_SOURCES += src/thread.c src/threadchangepriority.c \
src/threadclearstate.c src/threadclose.c src/threadcreateidle.c \
src/threaddelayended.c src/threaddispatch.c src/threadevaluatemode.c \
- src/threadhandler.c src/threadidlebody.c \
+ src/threadget.c src/threadhandler.c src/threadidlebody.c \
src/threadinitialize.c src/threadloadenv.c src/threadready.c \
src/threadresettimeslice.c src/threadreset.c src/threadrestart.c \
src/threadresume.c src/threadrotatequeue.c src/threadsetpriority.c \