summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-03-18 14:03:01 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-03-18 15:36:58 +0100
commit5a5fb3b9d6d99d6751d129458217f1a3b5b85ff8 (patch)
tree9f2296b7e4abaa0da454caea84e2fcbc0eb49fd2 /cpukit/score/Makefile.am
parentscore: Add _Objects_Get_by_name() (diff)
downloadrtems-5a5fb3b9d6d99d6751d129458217f1a3b5b85ff8.tar.bz2
score: Avoid Giant lock for CORE spinlock
Use an ISR lock to protect the spinlock state. Remove empty attributes. Update #2555.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index b6824ad446..6ff4e02adf 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -194,7 +194,7 @@ libscore_a_SOURCES += src/coresem.c
## CORE_SPINLOCK_C_FILES
if HAS_PTHREADS
-libscore_a_SOURCES += src/corespinlock.c src/corespinlockrelease.c \
+libscore_a_SOURCES += src/corespinlockrelease.c \
src/corespinlockwait.c
endif