summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-02-28 18:06:37 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-03-05 11:36:40 +0100
commit43e1573c1f02194a4fa754dfbff51862130742a5 (patch)
treefa7aed77417ebfc87cf9cb00c81c5a1533db7aa8 /cpukit/score/Makefile.am
parentscore: Thread dispatch dis/enable without Giant (diff)
downloadrtems-43e1573c1f02194a4fa754dfbff51862130742a5.tar.bz2
score: Add ISR lock to Objects_Control
This enables per-object SMP locks on SMP configurations and is the first step to support fine-grained locking. On uni-processor configuration there will be no overhead. The _Objects_Acquire() is intended to replace _Objects_Get_isr_disable(). Update #2273.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index a2d440b255..509a243c11 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -202,6 +202,7 @@ libscore_a_SOURCES += src/objectallocate.c src/objectclose.c \
src/objectgetinfo.c src/objectgetinfoid.c src/objectapimaximumclass.c \
src/objectnamespaceremove.c \
src/objectactivecount.c
+libscore_a_SOURCES += src/objectacquire.c
## SCHEDULER_C_FILES
libscore_a_SOURCES += src/log2table.c