summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
commit3d1de205f620197d40ad019eb2d9e2dd5f0525c2 (patch)
treee4feaad3efa5aede8330a49535ef909658e24c77 /cpukit/score/Makefile.am
parent2004-01-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-3d1de205f620197d40ad019eb2d9e2dd5f0525c2.tar.bz2
2004-01-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index a149255431..ab4af5f5ca 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -161,12 +161,13 @@ all-local: $(PREINSTALL_FILES) libscore$(LIB_VARIANT).a
DISTCLEANFILES = include/rtems/score/cpuopts.h
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/rtems/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems
@: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/debug.h: include/rtems/debug.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/debug.h
@@ -183,7 +184,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/seterr.h
$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/score/address.h: include/rtems/score/address.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/address.h
@@ -483,6 +484,7 @@ endif
endif
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES += $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/subdirs.am
include $(top_srcdir)/automake/local.am