summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-15 12:37:36 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-15 13:42:30 -0500
commit32506647001a815e3c0daf25757d386104a07184 (patch)
tree8ab18c675b7617011d405e915e00d455d18ea334 /cpukit/score/Makefile.am
parentThread Queue Priority Discipline Reimplemented with RBTree (diff)
downloadrtems-32506647001a815e3c0daf25757d386104a07184.tar.bz2
Thread Queue: Merge discipline subroutines into main methods
There was a lot of duplication between the discipline subroutines. With the transition to RBTrees for priority discipline, there were only a few lines of source code manipulating the data structure for FIFO and priority. Thus is made sense to fold these back into the main methods. As part of doing this all of the tests for discipline were changed to be in the same order.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index e4c373c836..431dade665 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -298,13 +298,9 @@ endif
## THREADQ_C_FILES
libscore_a_SOURCES += src/threadq.c src/threadqdequeue.c \
- src/threadqdequeuefifo.c src/threadqdequeuepriority.c \
- src/threadqenqueue.c src/threadqenqueuefifo.c \
- src/threadqenqueuepriority.c src/threadqextract.c \
- src/threadqextractfifo.c src/threadqextractpriority.c \
- src/threadqextractwithproxy.c src/threadqfirst.c src/threadqfirstfifo.c \
- src/threadqfirstpriority.c src/threadqflush.c \
- src/threadqprocesstimeout.c src/threadqtimeout.c
+ src/threadqenqueue.c src/threadqextract.c src/threadqrequeue.c \
+ src/threadqextractwithproxy.c src/threadqfirst.c \
+ src/threadqflush.c src/threadqprocesstimeout.c src/threadqtimeout.c
## TIMESPEC_C_FILES
libscore_a_SOURCES += src/timespecaddto.c src/timespecfromticks.c \