summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorWeiY <wei.a.yang@gmail.com>2013-07-15 23:31:13 +0800
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-07-17 13:07:33 +0200
commit2e7f57986576cf19b20f0fa8a9e8edd810215c73 (patch)
treea9090f44c914871b4c9a6958ec7df51e4adad46d /cpukit/score/Makefile.am
parentsmpatomic test case update (diff)
downloadrtems-2e7f57986576cf19b20f0fa8a9e8edd810215c73.tar.bz2
stdatomic.h support check when configure
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 82bf26d4ae..338c797a30 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -60,10 +60,12 @@ include_rtems_score_HEADERS += include/rtems/score/watchdog.h
include_rtems_score_HEADERS += include/rtems/score/wkspace.h
include_rtems_score_HEADERS += include/rtems/score/cpuopts.h
include_rtems_score_HEADERS += include/rtems/score/basedefs.h
+if ATOMIC
include_rtems_score_HEADERS += include/rtems/score/atomic.h
include_rtems_score_HEADERS += include/rtems/score/genericcpuatomic.h
include_rtems_score_HEADERS += include/rtems/score/genericatomicops.h
include_rtems_score_HEADERS += include/rtems/score/cpustdatomic.h
+endif
if HAS_PTHREADS
include_rtems_score_HEADERS += include/rtems/score/corespinlock.h