summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-25 10:54:49 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-31 08:29:43 +0200
commit1b1be254e7a3e3d6fe6d55d62010a81a7ef35411 (patch)
treec8bacf15b0f092728fd69debcb2387b65db33ed0 /cpukit/score/Makefile.am
parentscore: Replace _Thread_Reset() (diff)
downloadrtems-1b1be254e7a3e3d6fe6d55d62010a81a7ef35411.tar.bz2
score: Thread life cycle re-implementation
The thread deletion is now supported on SMP. This change fixes the following PRs: PR1814: SMP race condition between stack free and dispatch PR2035: psxcancel reveals NULL pointer access in _Thread_queue_Extract() The POSIX cleanup handler are now called in the right context (should be called in the context of the terminating thread). http://pubs.opengroup.org/onlinepubs/009695399/functions/xsh_chap02_09.html Add a user extension the reflects a thread termination event. This is used to reclaim the Newlib reentrancy structure (may use file operations), the POSIX cleanup handlers and the POSIX key destructors.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index c6dd47b781..e2d23a4a69 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -272,7 +272,7 @@ libscore_a_SOURCES += src/rbtree.c \
## THREAD_C_FILES
libscore_a_SOURCES += src/thread.c src/threadchangepriority.c \
- src/threadclearstate.c src/threadclose.c src/threadcreateidle.c \
+ src/threadclearstate.c src/threadcreateidle.c \
src/threaddelayended.c src/threaddispatch.c \
src/threadenabledispatch.c src/threaddisabledispatch.c \
src/threadget.c src/threadhandler.c src/threadinitialize.c \