summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-02-18 15:12:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-02-18 15:12:44 +0000
commit108c4b085ccf88e9644fccbf5cec1b79c39e67e4 (patch)
treedf0df1d699d02955750d1691e75ef26fe0c8e1b1 /cpukit/score/Makefile.am
parent2011-02-17 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-108c4b085ccf88e9644fccbf5cec1b79c39e67e4.tar.bz2
2011-02-18 Joel Sherrill <joel.sherrill@oarcorp.com>
* sapi/include/confdefs.h, score/Makefile.am, score/include/rtems/score/scheduler.h, score/include/rtems/score/schedulerpriority.h, score/include/rtems/score/thread.h, score/inline/rtems/score/scheduler.inl, score/inline/rtems/score/schedulerpriority.inl, score/src/scheduler.c, score/src/schedulerpriority.c, score/src/schedulerpriorityblock.c, score/src/schedulerpriorityschedule.c, score/src/schedulerpriorityunblock.c, score/src/schedulerpriorityyield.c, score/src/threadchangepriority.c, score/src/threadclose.c, score/src/threadinitialize.c, score/src/threadsetpriority.c, score/src/threadsettransient.c: Significant clean up on Scheduler Plugin Interface. Names were shortened. Missing operations added. Many scheduler files had unneeded includes removed. Made pointer to scheduler information in Thread_Control and Scheduler_Control a void * pointer because the thread and scheduler wrapper should be unaware of scheduler types AND this is broken for user provided schedulers. * score/src/schedulerpriorityallocate.c, score/src/schedulerpriorityenqueue.c, score/src/schedulerpriorityenqueuefirst.c, score/src/schedulerpriorityextract.c, score/src/schedulerpriorityfree.c, score/src/schedulerpriorityupdate.c: New files. * score/src/schedulerprioritythreadschedulerallocate.c, score/src/schedulerprioritythreadschedulerfree.c, score/src/schedulerprioritythreadschedulerupdate.c: Removed.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index fbe50e1244..55963b7879 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -144,13 +144,16 @@ libscore_a_SOURCES += src/scheduler.c
## SCHEDULERPRIORITY_C_FILES
libscore_a_SOURCES += src/schedulerpriority.c \
- src/schedulerpriorityblock.c \
- src/schedulerprioritythreadschedulerallocate.c \
- src/schedulerprioritythreadschedulerfree.c \
- src/schedulerprioritythreadschedulerupdate.c \
- src/schedulerpriorityschedule.c \
- src/schedulerpriorityunblock.c \
- src/schedulerpriorityyield.c
+ src/schedulerpriorityallocate.c \
+ src/schedulerpriorityblock.c \
+ src/schedulerpriorityenqueue.c \
+ src/schedulerpriorityenqueuefirst.c \
+ src/schedulerpriorityextract.c \
+ src/schedulerpriorityfree.c \
+ src/schedulerpriorityschedule.c \
+ src/schedulerpriorityunblock.c \
+ src/schedulerpriorityupdate.c \
+ src/schedulerpriorityyield.c
## PROTECTED_HEAP_C_FILES
libscore_a_SOURCES += src/pheapallocate.c \