summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-23 13:30:44 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-06 07:25:51 +0100
commit10827984c2cf54188a9af71b94a7e83197812bb5 (patch)
treed0faa328fff4ed71c72993675a231a1b6a0d710c /cpukit/score/Makefile.am
parentsmpscheduler02: Avoid sporadic test failures (diff)
downloadrtems-10827984c2cf54188a9af71b94a7e83197812bb5.tar.bz2
score: Add _IO_Printf() and _IO_Vprintf()
The previous vprintk() implementation had a questionable licence header, lacks support for the 'z' and 'j' format specifiers, is not robust against invalid format specifiers, uses a global variable for output. Replace it with a stripped down version of the FreeBSD kernel kvprintf() function. The new implementation allows a low overhead rtems_snprintf() if necessary. Update #3199. Close #3216.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 7ff1f41684..11bf59cca8 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -46,6 +46,7 @@ include_rtems_score_HEADERS += include/rtems/score/heap.h
include_rtems_score_HEADERS += include/rtems/score/heapimpl.h
include_rtems_score_HEADERS += include/rtems/score/protectedheap.h
include_rtems_score_HEADERS += include/rtems/score/interr.h
+include_rtems_score_HEADERS += include/rtems/score/io.h
include_rtems_score_HEADERS += include/rtems/score/isr.h
include_rtems_score_HEADERS += include/rtems/score/isrlevel.h
include_rtems_score_HEADERS += include/rtems/score/isrlock.h
@@ -333,6 +334,8 @@ libscore_a_SOURCES += src/chain.c \
src/chainnodecount.c \
src/debugisthreaddispatchingallowed.c \
src/interr.c src/isr.c src/wkspace.c src/wkstringduplicate.c
+libscore_a_SOURCES += src/ioprintf.c
+libscore_a_SOURCES += src/iovprintf.c
libscore_a_SOURCES += src/isrisinprogress.c
libscore_a_SOURCES += src/condition.c
libscore_a_SOURCES += src/debugisownerofallocator.c