summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-10 14:39:41 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-17 09:17:36 +0100
commit840ae715a9c1e45b31d7a493e9b5c4113e17bf62 (patch)
tree9c101a3db9e8b236df0b060d21d93758843182ef /cpukit/sapi/Makefile.am
parentscore: Add include for uintptr_t definition. (diff)
downloadrtems-840ae715a9c1e45b31d7a493e9b5c4113e17bf62.tar.bz2
sapi: Add <rtems/test.h>
Provide support functions to print the begin/end of test message. Provide a test fatal extension to print out profiling reports in the future.
Diffstat (limited to 'cpukit/sapi/Makefile.am')
-rw-r--r--cpukit/sapi/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/sapi/Makefile.am b/cpukit/sapi/Makefile.am
index 19f7d87f61..37a2fa4228 100644
--- a/cpukit/sapi/Makefile.am
+++ b/cpukit/sapi/Makefile.am
@@ -18,6 +18,7 @@ include_rtems_HEADERS += include/rtems/profiling.h
include_rtems_HEADERS += include/rtems/rbheap.h
include_rtems_HEADERS += include/rtems/rbtree.h
include_rtems_HEADERS += include/rtems/sptables.h
+include_rtems_HEADERS += include/rtems/test.h
include_rtems_HEADERS += include/rtems/timespec.h
EXTRA_DIST = include/rtems/README
@@ -39,6 +40,8 @@ libsapi_a_SOURCES += src/delayticks.c
libsapi_a_SOURCES += src/delaynano.c
libsapi_a_SOURCES += src/profilingiterate.c
libsapi_a_SOURCES += src/profilingreportxml.c
+libsapi_a_SOURCES += src/testbeginend.c
+libsapi_a_SOURCES += src/testextension.c
libsapi_a_CPPFLAGS = $(AM_CPPFLAGS)
include $(srcdir)/preinstall.am