summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-10 14:39:49 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-14 08:46:49 +0100
commit4dad4b84112d57cf6e77409f8e267706db446ec0 (patch)
tree6af69b581cc801a3f8355b9188ae98012f85f4af /cpukit/sapi/Makefile.am
parentscore: Add --enable-profiling configure option (diff)
downloadrtems-4dad4b84112d57cf6e77409f8e267706db446ec0.tar.bz2
sapi: Add profiling application level support
Diffstat (limited to 'cpukit/sapi/Makefile.am')
-rw-r--r--cpukit/sapi/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/sapi/Makefile.am b/cpukit/sapi/Makefile.am
index 63eb60595f..19f7d87f61 100644
--- a/cpukit/sapi/Makefile.am
+++ b/cpukit/sapi/Makefile.am
@@ -14,6 +14,7 @@ include_rtems_HEADERS += include/rtems/init.h
include_rtems_HEADERS += include/rtems/io.h
include_rtems_HEADERS += include/rtems/mptables.h
include_rtems_HEADERS += include/rtems/cbs.h
+include_rtems_HEADERS += include/rtems/profiling.h
include_rtems_HEADERS += include/rtems/rbheap.h
include_rtems_HEADERS += include/rtems/rbtree.h
include_rtems_HEADERS += include/rtems/sptables.h
@@ -36,6 +37,8 @@ libsapi_a_SOURCES += src/chainsmp.c
libsapi_a_SOURCES += src/cpucounterconverter.c
libsapi_a_SOURCES += src/delayticks.c
libsapi_a_SOURCES += src/delaynano.c
+libsapi_a_SOURCES += src/profilingiterate.c
+libsapi_a_SOURCES += src/profilingreportxml.c
libsapi_a_CPPFLAGS = $(AM_CPPFLAGS)
include $(srcdir)/preinstall.am