summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-25 19:42:21 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-25 19:42:21 +0000
commita6abd67af50cf087725951f082c39feea62ba02c (patch)
treea0fbc886f8230c4d6a67615b2a1ad1abd485ecb8 /cpukit/pppd/Makefile.am
parent2000-11-25 Antti P Miettinen <antti.p.miettinen@nokia.com> (diff)
downloadrtems-a6abd67af50cf087725951f082c39feea62ba02c.tar.bz2
2000-11-25 Antti P Miettinen <antti.p.miettinen@nokia.com>
* wrapup/Makefile.am: Added modem subdir. * configure.in, Makefile.am: Added modem subdir. * net/Makefile.am: Added if_pppvar.h, pppcompress.h. * pppd/Makefile.am: Added pppmain.c (which needs work). * pppd/chat.c, pppd/fsm.c, pppd/fsm.h, pppd/ipxcp.c, pppd/main.c, pppd/ppp_tty.c, pppd/upap.c: Changes from Thomas Doerfler <Thomas.Doerfler@imd-systems.de> and cosmetic changes by me. Actually main.c and ppp_tty.c should be scratched. The modem subdir has the real ppp_tty.c and the real pppd main is in pppmain.c.
Diffstat (limited to 'cpukit/pppd/Makefile.am')
-rw-r--r--cpukit/pppd/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
index dd78bc0c7a..836d2ab110 100644
--- a/cpukit/pppd/Makefile.am
+++ b/cpukit/pppd/Makefile.am
@@ -7,9 +7,10 @@ AUTOMAKE_OPTIONS = foreign 1.4
LIBNAME = lib.a
LIB = $(ARCH)/$(LIBNAME)
-# What to do about main.c?
+# renamed main.c to pppmain.c
C_FILES = auth.c cbcp.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c ipcp.c \
- ipxcp.c lcp.c magic.c options.c upap.c md4.c md5.c rtems-ppp.c
+ ipxcp.c lcp.c magic.c options.c upap.c md4.c md5.c rtems-ppp.c \
+ pppmain.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -40,6 +41,6 @@ EXTRA_DIST = README STATUS auth.c cbcp.c cbcp.h ccp.c ccp.h chap.c chap.h \
chap_ms.c chap_ms.h chat.c demand.c fsm.c fsm.h ipcp.c ipcp.h ipxcp.c \
ipxcp.h lcp.c lcp.h magic.c magic.h main.c md4.c md4.h md5.c md5.h \
options.c patchlevel.h pathnames.h ppp_tty.c pppd.h rtems-ppp.c upap.c \
- upap.h $(EXTRA_FILES)
+ upap.h pppmain.c $(EXTRA_FILES)
include $(top_srcdir)/../../../automake/local.am