summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-09 18:22:16 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-09 18:22:16 +0000
commitb71e8d050a743b620feee38315af7f605cb8f463 (patch)
treec333513b919d88666d0b5030bc9838e398d35228 /cpukit/posix/Makefile.am
parent2004-01-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-b71e8d050a743b620feee38315af7f605cb8f463.tar.bz2
2004-01-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add libs to CLEANFILES Set lib*_g_a_SOURCES = lib*_a_SOURCES.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 71f85a2d11..f6b08d76f0 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -150,11 +150,13 @@ AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
EXTRA_LIBRARIES = libposix.a
+CLEANFILES = libposix.a
libposix_a_SOURCES = $(C_FILES)
libposix_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
EXTRA_LIBRARIES += libposix_g.a
-libposix_g_a_SOURCES = $(C_FILES)
+CLEANFILES += libposix_g.a
+libposix_g_a_SOURCES = $(libposix_a_SOURCES)
libposix_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
all-local: $(PREINSTALL_FILES) libposix$(LIB_VARIANT).a