summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-17 16:01:42 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-17 16:01:42 +0000
commita6cbc9b8690825aebde9694e9132230d57d53847 (patch)
tree0974c40531822c54d167e4bdea37e57dca40ec9e /cpukit/posix/Makefile.am
parentFormatting. (diff)
downloadrtems-a6cbc9b8690825aebde9694e9132230d57d53847.tar.bz2
2007-12-17 Joel Sherrill <joel.sherrill@OARcorp.com>
* posix/Makefile.am, posix/preinstall.am, posix/include/rtems/posix/timer.h, score/src/objectget.c: Split POSIX Timer implementation into multiple files. Add obvious error checks for NULL parameters. Attempt to reduce include files. * posix/src/timercreate.c, posix/src/timerdelete.c, posix/src/timergetoverrun.c, posix/src/timergettime.c, posix/src/timerinserthelper.c, posix/src/timersettime.c, posix/src/timertsr.c: New files. * posix/src/ptimer1.c: Removed.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 4708af7989..bc8ae0b411 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -35,10 +35,11 @@ include_rtems_posix_HEADERS = include/rtems/posix/cancel.h \
include/rtems/posix/key.h include/rtems/posix/mqueue.h \
include/rtems/posix/mutex.h include/rtems/posix/posixapi.h \
include/rtems/posix/priority.h include/rtems/posix/psignal.h \
- include/rtems/posix/pthread.h include/rtems/posix/semaphore.h \
- include/rtems/posix/threadsup.h include/rtems/posix/time.h \
- include/rtems/posix/timer.h include/rtems/posix/barrier.h \
- include/rtems/posix/rwlock.h include/rtems/posix/spinlock.h
+ include/rtems/posix/pthread.h include/rtems/posix/ptimer.h \
+ include/rtems/posix/semaphore.h include/rtems/posix/threadsup.h \
+ include/rtems/posix/time.h include/rtems/posix/timer.h \
+ include/rtems/posix/barrier.h include/rtems/posix/rwlock.h \
+ include/rtems/posix/spinlock.h
include_rtems_posix_HEADERS += inline/rtems/posix/cond.inl \
inline/rtems/posix/key.inl inline/rtems/posix/mqueue.inl \
@@ -161,7 +162,9 @@ libposix_a_SOURCES += src/adjtime.c src/posixtimespecabsolutetimeout.c \
# the timer manager needs to be split further but only after its
# dependence on the Classic API Timer Manager is removed.
## TIMER_C_FILES
-libposix_a_SOURCES += src/ptimer.c src/ptimer1.c
+libposix_a_SOURCES += src/ptimer.c src/timercreate.c src/timerdelete.c \
+ src/timergetoverrun.c src/timergettime.c src/timersettime.c \
+ src/timertsr.c src/timerinserthelper.c
EXTRA_DIST += src/README.mqueue