summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2014-01-14 09:43:14 -0600
committerJennifer Averett <jennifer.averett@oarcorp.com>2014-03-07 09:12:41 -0600
commit6e5f2493a97e4d441ade2eccc1f5c474e71c01f3 (patch)
tree813cbf83982270348f2e93d77f2fcb2f5c51b844 /cpukit/posix/Makefile.am
parentposix: Add dynamic pthread get and set affinity. (diff)
downloadrtems-6e5f2493a97e4d441ade2eccc1f5c474e71c01f3.tar.bz2
posix: Add pthread_getattr_np().
This is a useful POSIX thread API helper which is found in `GNU/Linux and *BSD.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 9dc8820507..ccadd63630 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -130,6 +130,7 @@ libposix_a_SOURCES += src/pthreadatfork.c src/pthreadattrdestroy.c \
src/pthreadattrsetschedparam.c src/pthreadattrsetschedpolicy.c \
src/pthreadattrsetscope.c src/pthreadattrsetstackaddr.c \
src/pthreadattrsetstack.c src/pthreadattrsetstacksize.c \
+ src/pthreadgetattrnp.c \
src/pthreadattrgetguardsize.c src/pthread.c \
src/pthreadcreate.c src/pthreaddetach.c src/pthreadequal.c \
src/pthreadexit.c src/pthreadgetcpuclockid.c \