summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorGedare Bloom <gedare@rtems.org>2016-08-12 11:17:40 -0400
committerGedare Bloom <gedare@rtems.org>2017-01-13 11:05:56 -0500
commit1ca8ee137e9e7dc815e55cc06ebd2c2c4e2191be (patch)
treea1556767a5daaacb0f88616e5c5344f49745acab /cpukit/posix/Makefile.am
parentposix: move sys/mman.h to newlib and test it in psxhdrs (diff)
downloadrtems-1ca8ee137e9e7dc815e55cc06ebd2c2c4e2191be.tar.bz2
posix: add stub implementations for mman functions
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 8323de8f8b..53faacee70 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -89,9 +89,17 @@ libposix_a_SOURCES += src/cond.c src/condattrdestroy.c \
src/condtimedwait.c src/condwait.c src/condwaitsupp.c src/condget.c
## MEMORY_C_FILES
+libposix_a_SOURCES += src/mlockall.c
+libposix_a_SOURCES += src/mlock.c
libposix_a_SOURCES += src/mmap.c
libposix_a_SOURCES += src/mprotect.c
+libposix_a_SOURCES += src/msync.c
+libposix_a_SOURCES += src/munlockall.c
+libposix_a_SOURCES += src/munlock.c
libposix_a_SOURCES += src/munmap.c
+libposix_a_SOURCES += src/posix_madvise.c
+libposix_a_SOURCES += src/shmopen.c
+libposix_a_SOURCES += src/shmunlink.c
## MESSAGE_QUEUE_C_FILES
libposix_a_SOURCES += src/mqueue.c src/mqueueclose.c \