summaryrefslogtreecommitdiffstats
path: root/cpukit/librpc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 17:35:46 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 17:35:46 +0000
commitde48a0ea91a7b1cd334d0e2d8a1a815f38993abc (patch)
treedef731ed89f06bac9ef47941197066815387ff35 /cpukit/librpc/Makefile.am
parent2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-de48a0ea91a7b1cd334d0e2d8a1a815f38993abc.tar.bz2
2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add $(dirstamp) to compilation rules.
Diffstat (limited to 'cpukit/librpc/Makefile.am')
-rw-r--r--cpukit/librpc/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/cpukit/librpc/Makefile.am b/cpukit/librpc/Makefile.am
index 9c8140d89a..2bc7cdf14d 100644
--- a/cpukit/librpc/Makefile.am
+++ b/cpukit/librpc/Makefile.am
@@ -32,15 +32,16 @@ libxdr_C_O_FILES = \
libxdr_OBJS = $(libxdr_C_O_FILES)
-src/xdr/$(ARCH):
- @$(mkinstalldirs) $@
-src/xdr/$(ARCH)/%.$(OBJEXT): src/xdr/%.c
+src/xdr/$(ARCH)/$(dirstamp):
+ @$(mkinstalldirs) src/xdr/$(ARCH)
+ @: > src/xdr/$(ARCH)/$(dirstamp)
+src/xdr/$(ARCH)/%.$(OBJEXT): src/xdr/%.c src/xdr/$(ARCH)/$(dirstamp)
${COMPILE} -o $@ -c $<
src/xdr/$(ARCH)/libxdr.a: $(libxdr_OBJS)
$(make-library)
man_MANS += src/xdr/xdr.3
-all-local: src/xdr/$(ARCH) src/xdr/$(ARCH)/libxdr.a
+all-local: src/xdr/$(ARCH)/libxdr.a
endif
librpc_C_FILES = src/rpc/auth_none.c src/rpc/auth_unix.c \
@@ -71,9 +72,10 @@ librpc_OBJS = $(librpc_C_O_FILES)
librpc_a_CPPFLAGS = -D_RPC_read=read -D_RPC_write=write -D_RPC_close=close \
-D_RTEMS_RPC_INTERNAL_
-src/rpc/$(ARCH):
- @$(mkinstalldirs) $@
-src/rpc/$(ARCH)/%.$(OBJEXT): src/rpc/%.c
+src/rpc/$(ARCH)/$(dirstamp):
+ @$(mkinstalldirs) src/rpc/$(ARCH)
+ @: > src/rpc/$(ARCH)/$(dirstamp)
+src/rpc/$(ARCH)/%.$(OBJEXT): src/rpc/%.c src/rpc/$(ARCH)/$(dirstamp)
${COMPILE} $(librpc_a_CPPFLAGS) -o $@ -c $<
src/rpc/$(ARCH)/librpc.a: $(librpc_OBJS)
$(make-library)
@@ -83,7 +85,7 @@ man_MANS += src/rpc/bindresvport.3 src/rpc/getrpcent.3 src/rpc/publickey.3 \
src/rpc/des_crypt.3 src/rpc/getrpcport.3 src/rpc/publickey.5 \
src/rpc/rpc.5 src/rpc/rstat.1 src/rpc/rtime.3
-all-local: src/rpc/$(ARCH) src/rpc/$(ARCH)/librpc.a
+all-local: src/rpc/$(ARCH)/librpc.a
endif
CLEANDIRS += src/rpc