summaryrefslogtreecommitdiffstats
path: root/cpukit/librpc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-26 19:28:11 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-26 19:28:11 +0000
commitca7858bb8856f1afcc537f39763b7c951e5068d3 (patch)
tree3f01b3bb41ce9b2d7bc16c300391382918758caf /cpukit/librpc/Makefile.am
parentPort of RTEMS to the Texas Instruments C3x/C4x DSP families including (diff)
downloadrtems-ca7858bb8856f1afcc537f39763b7c951e5068d3.tar.bz2
Port of RTEMS to the Texas Instruments C3x/C4x DSP families including
a BSP (c4xsim) supporting the simulator included with gdb. This port was done by Joel Sherrill and Jennifer Averett of OAR Corporation. Also included with this port is a space/time optimization to eliminate FP context switch management on CPUs without hardware or software FP. An issue with this port was that sizeof(unsigned32) = sizeof(unsigned8) on this CPU. This required addressing alignment checks and assumptions as well as fixing code that assumed sizeof(unsigned32) == 4.
Diffstat (limited to 'cpukit/librpc/Makefile.am')
-rw-r--r--cpukit/librpc/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/cpukit/librpc/Makefile.am b/cpukit/librpc/Makefile.am
index d9429399ec..2377188d12 100644
--- a/cpukit/librpc/Makefile.am
+++ b/cpukit/librpc/Makefile.am
@@ -5,7 +5,11 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+if rpc_not_supported
+SUBDIRS =
+else
SUBDIRS = include src
+endif
EXTRA_DIST = README_RTEMS