summaryrefslogtreecommitdiffstats
path: root/cpukit/librpc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 05:31:43 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 05:31:43 +0000
commit8956e27932b47527b947c8632f11824ce893f99d (patch)
treef93ff56e830beca6719e891a3ad46835938680c6 /cpukit/librpc/Makefile.am
parent2004-01-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8956e27932b47527b947c8632f11824ce893f99d.tar.bz2
2004-01-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Re-add dirstamps to PREINSTALL_FILES. Add PREINSTALL_FILES to CLEANFILES.
Diffstat (limited to 'cpukit/librpc/Makefile.am')
-rw-r--r--cpukit/librpc/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/cpukit/librpc/Makefile.am b/cpukit/librpc/Makefile.am
index 8b758c45bd..92a69d46a8 100644
--- a/cpukit/librpc/Makefile.am
+++ b/cpukit/librpc/Makefile.am
@@ -6,6 +6,7 @@ include $(top_srcdir)/automake/multilib.am
include $(top_srcdir)/automake/compile.am
EXTRA_DIST =
+CLEANFILES =
if LIBRPC
include_rpcdir = $(includedir)/rpc
@@ -19,7 +20,7 @@ include_rpc_HEADERS = include/rpc/auth.h include/rpc/auth_des.h \
man_MANS =
EXTRA_LIBRARIES = libxdr.a
-CLEANFILES = libxdr.a
+CLEANFILES += libxdr.a
libxdr_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
EXTRA_LIBRARIES += libxdr_g.a
@@ -112,6 +113,7 @@ if LIBRPC
$(PROJECT_INCLUDE)/rpc/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rpc
@: > $(PROJECT_INCLUDE)/rpc/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rpc/$(dirstamp)
$(PROJECT_INCLUDE)/rpc/auth.h: include/rpc/auth.h $(PROJECT_INCLUDE)/rpc/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rpc/auth.h
@@ -178,4 +180,6 @@ $(PROJECT_INCLUDE)/rpc/xdr.h: include/rpc/xdr.h $(PROJECT_INCLUDE)/rpc/$(dirstam
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rpc/xdr.h
endif
+CLEANFILES += $(PREINSTALL_FILES)
+
include $(top_srcdir)/automake/local.am