summaryrefslogtreecommitdiffstats
path: root/cpukit/libpci/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2017-08-30 11:01:38 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2017-09-29 13:36:44 +0200
commitf9fbb3336ff4e9044795e02b2847bbc1206674f5 (patch)
treed74bd69e94b597ea75e8b82e78d6950905219b4e /cpukit/libpci/Makefile.am
parentbsp/bf537Stamp: Fix warning (diff)
downloadrtems-f9fbb3336ff4e9044795e02b2847bbc1206674f5.tar.bz2
libpci: fix pci device allocation
The refactoring of pci_dev_create() was incorrect since the code relied on different defines before including pci/cfg.h. This reverts back to the original code having two pci_dev_create() one in auto and one in read library. confdefs.h selectes between the two libraries so both there is no link conflict. Updates #3029
Diffstat (limited to 'cpukit/libpci/Makefile.am')
-rw-r--r--cpukit/libpci/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/cpukit/libpci/Makefile.am b/cpukit/libpci/Makefile.am
index cf336ed094..cff25b35c0 100644
--- a/cpukit/libpci/Makefile.am
+++ b/cpukit/libpci/Makefile.am
@@ -28,7 +28,6 @@ libpci_a_SOURCES += pci_cfg_print_code.c
libpci_a_SOURCES += pci_cfg_read.c
libpci_a_SOURCES += pci_cfg_static.c
libpci_a_SOURCES += pci_cfg_peripheral.c
-libpci_a_SOURCES += pci_dev_create.c
libpci_a_SOURCES += pci_find.c
libpci_a_SOURCES += pci_find_dev.c
libpci_a_SOURCES += pci_for_each.c