summaryrefslogtreecommitdiffstats
path: root/cpukit/libpci/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2011-11-28 10:16:09 +0100
committerDaniel Hellstrom <daniel@gaisler.com>2015-04-17 01:10:16 +0200
commit1c5a7e5e52d418af5fb85eb321f2eacdcad5853b (patch)
tree6658a0c48e47e919d8bc87e46fb0b27c963128f3 /cpukit/libpci/Makefile.am
parentDRVMGR: added driver manager to cpukit/libdrvmgr (diff)
downloadrtems-1c5a7e5e52d418af5fb85eb321f2eacdcad5853b.tar.bz2
LIBPCI: added DRVMGR model for PCI bus
Diffstat (limited to 'cpukit/libpci/Makefile.am')
-rw-r--r--cpukit/libpci/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/cpukit/libpci/Makefile.am b/cpukit/libpci/Makefile.am
index fd42a6fdcf..d7ca5ccba9 100644
--- a/cpukit/libpci/Makefile.am
+++ b/cpukit/libpci/Makefile.am
@@ -40,6 +40,11 @@ libpci_a_SOURCES += pci_get_dev.c
libpci_a_SOURCES += pci_irq.c
libpci_a_SOURCES += pci_print.c
+# Driver manager PCI bus
+libpci_a_SOURCES += pci_bus.c
+include_drvmgrdir = $(includedir)/drvmgr
+include_drvmgr_HEADERS = pci_bus.h
+
endif
include $(srcdir)/preinstall.am