summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/sys/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
commite6d8fe4717c301925408786aee585fb96912e445 (patch)
tree18a65119b8150bfc661d3fee629eb8361d4e7555 /cpukit/libnetworking/sys/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e6d8fe4717c301925408786aee585fb96912e445.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am, arpa/Makefile.am, machine/Makefile.am, net/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, rtems/Makefile.am, rtems_servers/Makefile.am, rtems_webserver/Makefile.am, sys/Makefile.am, vm/Makefile.am: Apply include_*HEADERS instead of H_FILES. * include/Makefile.am: Remove. * Makefile.am: Add handling of *.h files. * configure.in: Remove include/Makefile.
Diffstat (limited to 'cpukit/libnetworking/sys/Makefile.am')
-rw-r--r--cpukit/libnetworking/sys/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/cpukit/libnetworking/sys/Makefile.am b/cpukit/libnetworking/sys/Makefile.am
index b7fc58125d..abedf78d9c 100644
--- a/cpukit/libnetworking/sys/Makefile.am
+++ b/cpukit/libnetworking/sys/Makefile.am
@@ -4,16 +4,18 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = buf.h callout.h conf.h domain.h filio.h ioctl.h kernel.h libkern.h \
+
+
+include_sysdir = $(includedir)/sys
+
+include_sys_HEADERS = buf.h callout.h conf.h domain.h filio.h ioctl.h kernel.h libkern.h \
malloc.h mbuf.h mount.h param.h proc.h protosw.h queue.h reboot.h \
resourcevar.h rtprio.h select.h signalvar.h socket.h socketvar.h \
sockio.h sysctl.h syslimits.h syslog.h systm.h ttydefaults.h ucred.h \
uio.h un.h
-noinst_HEADERS = $(H_FILES)
-
PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \
- $(H_FILES:%=$(PROJECT_INCLUDE)/sys/%)
+ $(include_sys_HEADERS:%=$(PROJECT_INCLUDE)/sys/%)
$(PROJECT_INCLUDE)/sys:
@$(mkinstalldirs) $@