summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/nfs/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
commite6d8fe4717c301925408786aee585fb96912e445 (patch)
tree18a65119b8150bfc661d3fee629eb8361d4e7555 /cpukit/libnetworking/nfs/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e6d8fe4717c301925408786aee585fb96912e445.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am, arpa/Makefile.am, machine/Makefile.am, net/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, rtems/Makefile.am, rtems_servers/Makefile.am, rtems_webserver/Makefile.am, sys/Makefile.am, vm/Makefile.am: Apply include_*HEADERS instead of H_FILES. * include/Makefile.am: Remove. * Makefile.am: Add handling of *.h files. * configure.in: Remove include/Makefile.
Diffstat (limited to 'cpukit/libnetworking/nfs/Makefile.am')
-rw-r--r--cpukit/libnetworking/nfs/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/cpukit/libnetworking/nfs/Makefile.am b/cpukit/libnetworking/nfs/Makefile.am
index 2d9b4dcf4c..e4e6ef9f05 100644
--- a/cpukit/libnetworking/nfs/Makefile.am
+++ b/cpukit/libnetworking/nfs/Makefile.am
@@ -4,6 +4,8 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_nfsdir = $(includedir)/nfs
+
LIBNAME = lib.a
LIB = $(ARCH)/$(LIBNAME)
@@ -32,12 +34,10 @@ all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
EXTRA_DIST = bootp_subr.c
-H_FILES = krpc.h nfs.h nfsdiskless.h nfsproto.h rpcv2.h xdr_subs.h
-
-noinst_HEADERS = $(H_FILES)
+include_nfs_HEADERS = krpc.h nfs.h nfsdiskless.h nfsproto.h rpcv2.h xdr_subs.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/nfs \
- $(H_FILES:%=$(PROJECT_INCLUDE)/nfs/%)
+ $(include_nfs_HEADERS:%=$(PROJECT_INCLUDE)/nfs/%)
$(PROJECT_INCLUDE)/nfs:
@$(mkinstalldirs) $@