summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/nfs/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
commitdf49c60c9671e4a28e636964d744c1f59fb6cb68 (patch)
treeeabd85e189514ad412a35414ba5d483dcda3ef1f /cpukit/libnetworking/nfs/Makefile.am
parentPurged as many egcs references as possible. (diff)
downloadrtems-df49c60c9671e4a28e636964d744c1f59fb6cb68.tar.bz2
Merged from 4.5.0-beta3a
Diffstat (limited to 'cpukit/libnetworking/nfs/Makefile.am')
-rw-r--r--cpukit/libnetworking/nfs/Makefile.am22
1 files changed, 17 insertions, 5 deletions
diff --git a/cpukit/libnetworking/nfs/Makefile.am b/cpukit/libnetworking/nfs/Makefile.am
index 51184e47ae..9a8b43e31a 100644
--- a/cpukit/libnetworking/nfs/Makefile.am
+++ b/cpukit/libnetworking/nfs/Makefile.am
@@ -1,6 +1,6 @@
-##
+##
## $Id$
-##
+##
AUTOMAKE_OPTIONS = foreign 1.4
@@ -25,11 +25,23 @@ AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
$(LIB): $(OBJS)
$(make-library)
-all-local: $(ARCH) $(OBJS) $(LIB)
+all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
.PRECIOUS: $(LIB)
-EXTRA_DIST = bootp_subr.c krpc.h nfs.h nfsdiskless.h nfsproto.h rpcv2.h \
- xdr_subs.h
+EXTRA_DIST = bootp_subr.c
+
+H_FILES = krpc.h nfs.h nfsdiskless.h nfsproto.h rpcv2.h xdr_subs.h
+
+noinst_HEADERS = $(H_FILES)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/nfs $(H_FILES:%=$(PROJECT_INCLUDE)/nfs/%)
+
+$(PROJECT_INCLUDE)/nfs:
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/nfs/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
include $(top_srcdir)/../../../automake/local.am