summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-11-15 14:55:12 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-11-15 14:55:12 +0000
commit471bcf071f4bd1ce27895d72f0e2373cf348b2af (patch)
tree8eedb47452299987f2a0450f1c986e8ac3a4bda7 /cpukit/libnetworking/Makefile.am
parent2002-11-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-471bcf071f4bd1ce27895d72f0e2373cf348b2af.tar.bz2
2002-11-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in arpa/Makefile.am, machine/Makefile.am, sys/Makefile.am, vm/Makefile.am. Add . to SUBDIRS. * arpa/Makefile.am: Remove. * machine/Makefile.am: Remove. * sys/Makefile.am: Remove. * vm/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am62
1 files changed, 60 insertions, 2 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 3fac1286fe..633f7a43b1 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -4,7 +4,7 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-SUBDIRS = arpa kern machine sys vm lib libc net netinet nfs rtems
+SUBDIRS = . kern lib libc net netinet nfs rtems
SUBDIRS += wrapup
## poll.h is not in the list because RTEMS does not have poll()
@@ -13,11 +13,69 @@ include_HEADERS = \
bpfilter.h loop.h netdb.h opt_ipfw.h opt_mrouting.h \
opt_tcpdebug.h resolv.h syslog.h memory.h
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+
PREINSTALL_FILES = $(PROJECT_INCLUDE) \
$(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-$(PROJECT_INCLUDE):
+# arpa
+
+include_arpadir = $(includedir)/arpa
+
+include_arpa_HEADERS = arpa/ftp.h arpa/inet.h arpa/nameser.h \
+ arpa/nameser_compat.h arpa/telnet.h
+
+$(PROJECT_INCLUDE)/arpa:
+ @$(mkinstalldirs) $@
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/arpa \
+ $(include_arpa_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+## machine
+
+include_machinedir = $(includedir)/machine
+
+include_machine_HEADERS = machine/conf.h machine/cpu.h machine/cpufunc.h \
+ machine/endian.h machine/in_cksum.h machine/vmparam.h
+
+$(PROJECT_INCLUDE)/machine:
+ @$(mkinstalldirs) $@
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/machine \
+ $(include_machine_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+# sys
+
+include_sysdir = $(includedir)/sys
+
+include_sys_HEADERS = sys/buf.h sys/callout.h sys/conf.h sys/domain.h \
+ sys/kernel.h sys/libkern.h sys/malloc.h sys/mbuf.h sys/mount.h \
+ sys/proc.h sys/protosw.h sys/queue.h sys/reboot.h sys/resourcevar.h \
+ sys/rtprio.h sys/select.h sys/signalvar.h sys/socket.h sys/socketvar.h \
+ sys/sysctl.h sys/syslog.h sys/systm.h sys/ttydefaults.h sys/ucred.h \
+ sys/uio.h sys/un.h
+
+$(PROJECT_INCLUDE)/sys:
+ @$(mkinstalldirs) $@
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \
+ $(include_sys_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+# vm
+
+include_vmdir = $(includedir)/vm
+
+include_vm_HEADERS = vm/vm.h vm/vm_extern.h vm/vm_kern.h vm/vm_param.h
+
+$(PROJECT_INCLUDE)/vm:
@$(mkinstalldirs) $@
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/vm \
+ $(include_vm_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+# ---
+
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@