summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-04-02 01:15:37 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-04-02 01:15:37 +0000
commit2c9df304f5662a3f885ad5513b5f3180ba7c382c (patch)
tree6fe69b1daafcbb3c4e74a9ad644a7cea207117bd /cpukit/libnetworking/Makefile.am
parent2004-04-01 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-2c9df304f5662a3f885ad5513b5f3180ba7c382c.tar.bz2
2004-04-01 Ralf Corsepius <ralf_corsepius@rtems.org>
* libnetworking/poll.h: Replace with sys/poll.h wrapper. * libnetworking/sys/poll.h: New (Original FreeBSD file). * libnetworking/Makefile.am: Don't install opt_ipfw.h, opt_mrouting.h, opt_tcpdebug.h. Add sys/poll.h.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am22
1 files changed, 8 insertions, 14 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 57d3398455..bb6bfd7b22 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -10,7 +10,10 @@ AM_CPPFLAGS += -I$(top_builddir)
EXTRA_DIST = README
CLEANFILES =
+# poll is not supported
UNUSED_FILES = poll.h
+# Original FreeBSD file
+UNUSED_FILES += sys/poll.h
UNUSED_FILES += net/zlib.c net/zlib.h
UNUSED_FILES += net/ppp.h net/ppp-deflate.c net/bsd-comp.c
@@ -35,8 +38,11 @@ TMP_LIBS = libnetworking$(LIB_VARIANT).a
## poll.h is not in the list because RTEMS does not have poll()
## and installing poll.h confuses autoconf.
-include_HEADERS = bpfilter.h loop.h netdb.h opt_ipfw.h opt_mrouting.h \
- opt_tcpdebug.h resolv.h syslog.h memory.h
+include_HEADERS = bpfilter.h loop.h netdb.h
+include_HEADERS += resolv.h syslog.h memory.h
+
+libnetworking_a_SOURCES += opt_ipfw.h opt_mrouting.h opt_tcpdebug.h
+
# arpa
include_arpadir = $(includedir)/arpa
@@ -224,18 +230,6 @@ $(PROJECT_INCLUDE)/netdb.h: netdb.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/netdb.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/netdb.h
-$(PROJECT_INCLUDE)/opt_ipfw.h: opt_ipfw.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/opt_ipfw.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/opt_ipfw.h
-
-$(PROJECT_INCLUDE)/opt_mrouting.h: opt_mrouting.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/opt_mrouting.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/opt_mrouting.h
-
-$(PROJECT_INCLUDE)/opt_tcpdebug.h: opt_tcpdebug.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/opt_tcpdebug.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/opt_tcpdebug.h
-
$(PROJECT_INCLUDE)/resolv.h: resolv.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/resolv.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/resolv.h