summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-25 19:00:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-25 19:00:35 +0000
commit26cdc2aff41927292e2b68201c345d6ff75d3721 (patch)
tree2cfed0f83211ba2d7c0042b8841383c7e181fcff /cpukit/libnetworking/Makefile.am
parent2003-03-25 Thomas Doerfler <Thomas.Doerfler@imd-systems.de> (diff)
downloadrtems-26cdc2aff41927292e2b68201c345d6ff75d3721.tar.bz2
2002-03-25 Eric Norum <norume@aps.anl.gov>
PR 374/networking * Makefile.am, rtems/rtems_bsdnet.h, rtems/rtems_glue.c: The patch sent as part of PR270 got applied to the wrong place. The effect was that (1) startup was no faster than before and (2) malloc starvation messages came way too quickly. The attached patch fixes both these problems and also provides a mechanism for applications to handle malloc starvation conditions as they see fit. * rtems/rtems_bsdnet_malloc_starvation.c: New file.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 793e0c1759..1fb550e079 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -159,7 +159,8 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
rtems_C_FILES = rtems/sghostname.c rtems/issetugid.c rtems/rtems_glue.c rtems/rtems_syscall.c \
rtems/rtems_bootp.c rtems/rtems_showmbuf.c rtems/rtems_showroute.c rtems/rtems_showifstat.c \
rtems/rtems_showipstat.c rtems/rtems_showicmpstat.c rtems/rtems_showtcpstat.c \
- rtems/rtems_showudpstat.c rtems/rtems_select.c rtems/mkrootfs.c
+ rtems/rtems_showudpstat.c rtems/rtems_select.c rtems/mkrootfs.c \
+ rtems/rtems_bsdnet_malloc_starvation.c
OBJS += $(rtems_C_FILES:rtems/%.c=$(ARCH)/%.$(OBJEXT))
$(ARCH)/%.$(OBJEXT): rtems/%.c