summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-04-22 09:14:34 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-04-22 09:25:11 +0200
commit1641088178538e4ae409d53bbcbbb06fa80ffca0 (patch)
tree6b32afcc32f8f82c2e20c517bdbc71e14afae7f2 /cpukit/libnetworking/Makefile.am
parentnetwork: Delete unused in4_cksum() (diff)
downloadrtems-1641088178538e4ae409d53bbcbbb06fa80ffca0.tar.bz2
network: Ensure matching syscall prototypes
Ensure that kernel and user space system call protoypes are identical.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 2a8e06aafd..4f3dd0c4f8 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -255,6 +255,7 @@ lib_a_CPPFLAGS = $(AM_CPPFLAGS) $(lib_CPPFLAGS) -D__BSD_VISIBLE
lib_a_SOURCES = lib/getprotoby.c lib/rtems_bsdnet_ntp.c lib/ftpfs.c \
lib/syslog.c lib/tftpDriver.c
+lib_a_SOURCES += rtems/rtems_syscall_api.c
endif
EXTRA_DIST += $(UNUSED_FILES)