summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 12:21:36 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 12:21:36 +0000
commit14d34d841ed0832fa3998d70c679e2369a70d5ee (patch)
tree1ca63b0ed0df7b25bbc4a6f8e143cc7cd37f3c53 /cpukit/libnetworking/Makefile.am
parent2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-14d34d841ed0832fa3998d70c679e2369a70d5ee.tar.bz2
2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Remove (Merged into ../configure.ac). * Makefile.am, libc/Makefile.am, lib/Makefile.am, wrapup/Makefile.am: Reflect having merged configure.ac into ../configure.ac. * kern/kern_mib.c: Use RTEMS_VERSION to setup osrelease.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 1fb550e079..cbead878bf 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -4,9 +4,9 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-include $(top_srcdir)/../automake/multilib.am
-include $(top_srcdir)/../automake/compile.am
-include $(top_srcdir)/../automake/lib.am
+include $(top_srcdir)/automake/multilib.am
+include $(top_srcdir)/automake/compile.am
+include $(top_srcdir)/automake/lib.am
# Add -DFORWARD_PROTOCOL to enable UDP forwarding -- requires missing net/pf.h
AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
@@ -17,6 +17,7 @@ LIB = $(ARCH)/libnetworking.a
SUBDIRS = . lib libc
SUBDIRS += wrapup
+if HAS_NETWORKING
## poll.h is not in the list because RTEMS does not have poll()
## and installing poll.h confuses autoconf.
include_HEADERS = \
@@ -207,5 +208,7 @@ $(LIB): $(OBJS)
all-local: $(PREINSTALL_FILES) $(ARCH) $(LIB)
-include $(top_srcdir)/../automake/subdirs.am
-include $(top_srcdir)/../automake/local.am
+endif
+
+include $(top_srcdir)/automake/subdirs.am
+include $(top_srcdir)/automake/local.am