summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-05 19:37:55 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-05 19:37:55 +0000
commite152ecb7ec415c7f73fcf39c3dfdda4f90035011 (patch)
tree9ee312af98ddb4fe7f28cd5c01f36d495c12304c /cpukit/libmisc/Makefile.am
parent2009-08-05 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-e152ecb7ec415c7f73fcf39c3dfdda4f90035011.tar.bz2
2009-08-05 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, preinstall.am, libmisc/Makefile.am, wrapup/Makefile.am: Add new BSP Boot Command Line helper routines. Recently boot_card() has grown the ability to have a command line string pointer. These routines provide an interface to that string.
Diffstat (limited to 'cpukit/libmisc/Makefile.am')
-rw-r--r--cpukit/libmisc/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/cpukit/libmisc/Makefile.am b/cpukit/libmisc/Makefile.am
index f0a409d94d..fa296cccc7 100644
--- a/cpukit/libmisc/Makefile.am
+++ b/cpukit/libmisc/Makefile.am
@@ -8,6 +8,12 @@ EXTRA_DIST = README
noinst_LIBRARIES =
+## bspcmdline
+noinst_LIBRARIES += libbspcmdline.a
+libbspcmdline_a_SOURCES = bspcmdline/bspcmdline_get.c \
+ bspcmdline/bspcmdline_getparam.c bspcmdline/bspcmdline_getparamraw.c \
+ bspcmdline/bspcmdline_getparamrhs.c
+
## capture
EXTRA_DIST += capture/README
@@ -23,7 +29,6 @@ libcpuuse_a_SOURCES = cpuuse/cpuusagereport.c cpuuse/cpuusagereset.c \
cpuuse/cpuuse.h cpuuse/cpuusagedata.c
## devnull
-
noinst_LIBRARIES += libdevnull.a
libdevnull_a_SOURCES = devnull/devnull.c devnull/devnull.h