summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-18 20:36:40 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-18 20:36:40 +0000
commit543fe820616f31350366ab61052050303d17dd25 (patch)
treea2e4702be2cd9988ed341586c1c8c976b8ba3bb8 /cpukit/libmisc/Makefile.am
parent2007-12-18 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-543fe820616f31350366ab61052050303d17dd25.tar.bz2
2007-12-18 Joel Sherrill <joel.sherrill@oarcorp.com>
* libcsupport/Makefile.am, libcsupport/preinstall.am, libcsupport/src/malloc.c, libcsupport/src/mallocinfo.c, libmisc/Makefile.am, libmisc/shell/main_mallocinfo.c, libmisc/shell/shellconfig.h: Split malloc.c into multiple files with one function per file. Also split out statistics into a separate file which can be plugged in dynamically. Right now, it is always in. I suspect that splitting the file removed more code than leaving statistics in. I tinkered with malloc information command in the shell. I resurrected the malloc arena code as malloc boundary. This code is now compiled all the time even though it does not appear to work. * libcsupport/include/rtems/malloc.h, libcsupport/src/_calloc_r.c, libcsupport/src/_free_r.c, libcsupport/src/_malloc_r.c, libcsupport/src/_realloc_r.c, libcsupport/src/calloc.c, libcsupport/src/free.c, libcsupport/src/malloc_boundary.c, libcsupport/src/malloc_get_statistics.c, libcsupport/src/malloc_initialize.c, libcsupport/src/malloc_p.h, libcsupport/src/malloc_report_statistics.c, libcsupport/src/malloc_report_statistics_plugin.c, libcsupport/src/malloc_statistics_helpers.c, libcsupport/src/malloc_walk.c, libcsupport/src/realloc.c, libmisc/shell/main_perioduse.c: New files.
Diffstat (limited to 'cpukit/libmisc/Makefile.am')
-rw-r--r--cpukit/libmisc/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/cpukit/libmisc/Makefile.am b/cpukit/libmisc/Makefile.am
index 984bcaf8c9..19679c53d4 100644
--- a/cpukit/libmisc/Makefile.am
+++ b/cpukit/libmisc/Makefile.am
@@ -77,12 +77,12 @@ libshell_a_SOURCES = shell/cat_file.c shell/cmds.c shell/internal.h \
shell/main_mdump.c shell/main_medit.c shell/main_mfill.c \
shell/main_mkdir.c shell/main_mount.c $(shell_mount_fs) \
shell/main_mount_msdos.c shell/main_mmove.c shell/main_msdosfmt.c \
- shell/main_mwdump.c shell/main_pwd.c shell/main_rm.c shell/main_rmdir.c \
- shell/main_stackuse.c shell/main_tty.c shell/main_umask.c \
- shell/main_unmount.c shell/main_blksync.c shell/main_whoami.c \
- shell/shell.c shell/shell_cmdset.c shell/shellconfig.c \
- shell/shellconfig.h shell/shell.h shell/shell_makeargs.c \
- shell/str2int.c shell/write_file.c
+ shell/main_mwdump.c shell/main_perioduse.c shell/main_pwd.c \
+ shell/main_rm.c shell/main_rmdir.c shell/main_stackuse.c \
+ shell/main_tty.c shell/main_umask.c shell/main_unmount.c \
+ shell/main_blksync.c shell/main_whoami.c shell/shell.c \
+ shell/shell_cmdset.c shell/shellconfig.c shell/shellconfig.h \
+ shell/shell.h shell/shell_makeargs.c shell/str2int.c shell/write_file.c
endif
EXTRA_DIST += shell/README