summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2007-12-22 08:27:18 +0000
committerChris Johns <chrisj@rtems.org>2007-12-22 08:27:18 +0000
commit1ff9922df0f6e5f129299847d0f5eccbc8d6806c (patch)
tree07d27ca9b48c51998530281353a246286fdf1698 /cpukit/libmisc/Makefile.am
parent2007-12-21 Xi Yang <hiyangxi@gmail.com> (diff)
downloadrtems-1ff9922df0f6e5f129299847d0f5eccbc8d6806c.tar.bz2
2007-12-22 Chris Johns <chrisj@rtems.org>
* configure.ac: fixed bug that always enabled strict order mutexes. * score/inline/rtems/score/coremutex.inl: Fixed coding standard. * score/src/coremutex.c: Add the holder's thread to the lock_mutex list if the mutex is initialised locked. * libnetworking/rtems/rtems_glue.c: Changed semaphore error message to show the error is an rtems-net error. * libmisc/monitor/mon-network.c: Removed warnings. * telnetd/icmds.c: Changed shell_* to rtems_shell_*. * score/Makefile.am: Fixed typo that stopped 'make tags' working. * libmisc/shell/err.c, libmisc/shell/err.h, libmisc/shell/errx.c, libmisc/shell/extern-cp.h, libmisc/shell/fts.c, libmisc/shell/fts.h, libmisc/shell/main_cp.c, libmisc/shell/utils-cp.c, libmisc/shell/verr.c, libmisc/shell/verrx.c, libmisc/shell/vwarn.c, libmisc/shell/vwarnx.c, libmisc/shell/warn.c, libmisc/shell/warnx.c: New. Ported from BSD. * libmisc/shell/shellconfig.h: Add the cp command. * libmisc/Makefile.am: Add the new files to the shell. * libmisc/shell/shell.c, libmisc/shell/shell.h: Add scripting support. * libblock/src/flashdisk.c: Fixed disk drive count size setting bug.
Diffstat (limited to 'cpukit/libmisc/Makefile.am')
-rw-r--r--cpukit/libmisc/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/cpukit/libmisc/Makefile.am b/cpukit/libmisc/Makefile.am
index 19679c53d4..53c6e63964 100644
--- a/cpukit/libmisc/Makefile.am
+++ b/cpukit/libmisc/Makefile.am
@@ -68,10 +68,11 @@ if LIBNETWORKING
shell_mount_fs = shell/main_mount_ftp.c shell/main_mount_nfs.c \
shell/main_mount_tftp.c
endif
+libshell_a_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/shell
libshell_a_SOURCES = shell/cat_file.c shell/cmds.c shell/internal.h \
shell/main_alias.c shell/main_cat.c shell/main_cd.c \
shell/main_chdir.c shell/main_chmod.c shell/main_chroot.c \
- shell/main_cpuuse.c shell/main_date.c shell/main_dir.c \
+ shell/main_cp.c shell/main_cpuuse.c shell/main_date.c shell/main_dir.c \
shell/main_exit.c shell/main_help.c shell/main_id.c \
shell/main_logoff.c shell/main_ls.c shell/main_mallocinfo.c \
shell/main_mdump.c shell/main_medit.c shell/main_mfill.c \
@@ -82,7 +83,10 @@ libshell_a_SOURCES = shell/cat_file.c shell/cmds.c shell/internal.h \
shell/main_tty.c shell/main_umask.c shell/main_unmount.c \
shell/main_blksync.c shell/main_whoami.c shell/shell.c \
shell/shell_cmdset.c shell/shellconfig.c shell/shellconfig.h \
- shell/shell.h shell/shell_makeargs.c shell/str2int.c shell/write_file.c
+ shell/shell.h shell/shell_makeargs.c shell/str2int.c shell/write_file.c \
+ shell/utils-cp.c shell/err.c shell/errx.c shell/verr.c shell/verrx.c \
+ shell/vwarn.c shell/vwarnx.c shell/warn.c shell/warnx.c \
+ shell/fts.c
endif
EXTRA_DIST += shell/README