summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2009-11-18 00:09:21 +0000
committerChris Johns <chrisj@rtems.org>2009-11-18 00:09:21 +0000
commit05404983e2eedd4801abc7433de57db59a51ad85 (patch)
tree2500c9f71eaaf7bbb83469604de22190e60e95d9 /cpukit/libmisc/Makefile.am
parent2009-11-17 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-05404983e2eedd4801abc7433de57db59a51ad85.tar.bz2
2009-11-18 Chris Johns <chrisj@rtems.org>
* libmisc/shell/main_getenv.c, libmisc/shell/main_setenv.c, libmisc/shell/main_unsetenv.c: New. The shell can now play with environment variables. * libmisc/Makefile.am, libmisc/shell/shellconfig.h: Add setenv, getenv, and unsetenv to the shell.
Diffstat (limited to 'cpukit/libmisc/Makefile.am')
-rw-r--r--cpukit/libmisc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/libmisc/Makefile.am b/cpukit/libmisc/Makefile.am
index cd0988921c..8955978608 100644
--- a/cpukit/libmisc/Makefile.am
+++ b/cpukit/libmisc/Makefile.am
@@ -95,7 +95,8 @@ libshell_a_SOURCES = shell/cat_file.c shell/cmds.c shell/internal.h \
shell/dd-misc.c shell/dd-position.c \
shell/main_hexdump.c shell/hexdump-conv.c shell/hexdump-display.c \
shell/hexdump-odsyntax.c shell/hexdump-parse.c shell/hexsyntax.c \
- shell/main_time.c shell/main_mknod.c
+ shell/main_time.c shell/main_mknod.c \
+ shell/main_setenv.c shell/main_getenv.c shell/main_unsetenv.c
if LIBNETWORKING
libshell_a_SOURCES += shell/main_mount_ftp.c shell/main_mount_tftp.c \