summaryrefslogtreecommitdiffstats
path: root/cpukit/libfs/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2010-02-18 00:24:25 +0000
committerChris Johns <chrisj@rtems.org>2010-02-18 00:24:25 +0000
commita9fa9b765df38cc5319ae734b5148fd47ebbfd8d (patch)
tree55ee28ea4a162bfb26c7a2cb6106b057beda70ae /cpukit/libfs/Makefile.am
parentThis commit was generated by cvs2svn to compensate for changes in r22658, (diff)
downloadrtems-a9fa9b765df38cc5319ae734b5148fd47ebbfd8d.tar.bz2
2010-02-18 Chris Johns <chrisj@rtems.org>
* libfs/src/rfs/rtems-rfs-bitmaps.c, libfs/src/rfs/rtems-rfs-bitmaps.h, libfs/src/rfs/rtems-rfs-bitmaps-ut.c, libfs/src/rfs/rtems-rfs-block.c, libfs/src/rfs/rtems-rfs-block.h, libfs/src/rfs/rtems-rfs-block-pos.h, libfs/src/rfs/rtems-rfs-buffer-bdbuf.c, libfs/src/rfs/rtems-rfs-buffer.c, libfs/src/rfs/rtems-rfs-buffer-devio.c, libfs/src/rfs/rtems-rfs-buffer.h, libfs/src/rfs/rtems-rfs-data.h, libfs/src/rfs/rtems-rfs-dir.c, libfs/src/rfs/rtems-rfs-dir.h, libfs/src/rfs/rtems-rfs-dir-hash.c, libfs/src/rfs/rtems-rfs-dir-hash.h, libfs/src/rfs/rtems-rfs-file.c, libfs/src/rfs/rtems-rfs-file.h, libfs/src/rfs/rtems-rfs-file-system.c, libfs/src/rfs/rtems-rfs-file-system-fwd.h, libfs/src/rfs/rtems-rfs-file-system.h, libfs/src/rfs/rtems-rfs-format.c, libfs/src/rfs/rtems-rfs-format.h, libfs/src/rfs/rtems-rfs-group.c, libfs/src/rfs/rtems-rfs-group.h, libfs/src/rfs/rtems-rfs.h, libfs/src/rfs/rtems-rfs-inode.c, libfs/src/rfs/rtems-rfs-inode.h, libfs/src/rfs/rtems-rfs-link.c, libfs/src/rfs/rtems-rfs-link.h, libfs/src/rfs/rtems-rfs-mutex.c, libfs/src/rfs/rtems-rfs-mutex.h, libfs/src/rfs/rtems-rfs-rtems.c, libfs/src/rfs/rtems-rfs-rtems-dev.c, libfs/src/rfs/rtems-rfs-rtems-dir.c, libfs/src/rfs/rtems-rfs-rtems-file.c, libfs/src/rfs/rtems-rfs-rtems.h, libfs/src/rfs/rtems-rfs-rtems-utils.c, libfs/src/rfs/rtems-rfs-shell.c, libfs/src/rfs/rtems-rfs-shell.h, libfs/src/rfs/rtems-rfs-trace.c, libfs/src/rfs/rtems-rfs-trace.h: New. * Makefile.am, preinstall.am, libfs/Makefile.am, wrapup/Makefile.am: Updated with the RFS support. * libfs/README: Updated after 10 years. * libblock/src/flashdisk.c, libblock/src/nvdisk.c, libblock/src/ramdisk-driver.c: Updated to the new error reporting in libblock. * libmisc/shell/main_ls.c, libmisc/shell/print-ls.c: Fix printing the size in long mode. * libnetworking/nfs/bootp_subr.c, libnetworking/rtems/rtems_bootp.c, libnetworking/rtems/rtems_bsdnet_internal.h: Return the BOOTP/DHCP to the forever behaviour of 4.9 with the ability to call BOOTP and control the process if required.
Diffstat (limited to 'cpukit/libfs/Makefile.am')
-rw-r--r--cpukit/libfs/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/cpukit/libfs/Makefile.am b/cpukit/libfs/Makefile.am
index 6eb3ead8e2..56cdaa0052 100644
--- a/cpukit/libfs/Makefile.am
+++ b/cpukit/libfs/Makefile.am
@@ -62,6 +62,21 @@ libdosfs_a_SOURCES += src/dosfs/msdos_create.c src/dosfs/msdos_dir.c \
src/dosfs/dosfs.h
endif
+# RFS
+noinst_LIBRARIES += librfs.a
+librfs_a_SOURCES = \
+ src/rfs/rtems-rfs-bitmaps.c src/rfs/rtems-rfs-block.c \
+ src/rfs/rtems-rfs-buffer-bdbuf.c src/rfs/rtems-rfs-buffer.c \
+ src/rfs/rtems-rfs-dir-hash.c src/rfs/rtems-rfs-file.c \
+ src/rfs/rtems-rfs-group.c src/rfs/rtems-rfs-inode.c \
+ src/rfs/rtems-rfs-rtems-dev.c src/rfs/rtems-rfs-rtems-utils.c \
+ src/rfs/rtems-rfs-rtems.c src/rfs/rtems-rfs-shell.c \
+ src/rfs/rtems-rfs-bitmaps-ut.c src/rfs/rtems-rfs-dir.c \
+ src/rfs/rtems-rfs-file-system.c src/rfs/rtems-rfs-format.c \
+ src/rfs/rtems-rfs-link.c src/rfs/rtems-rfs-mutex.c \
+ src/rfs/rtems-rfs-rtems-dir.c src/rfs/rtems-rfs-rtems-file.c \
+ src/rfs/rtems-rfs-trace.c
+
# ---
include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am