summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-29 17:28:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-29 17:28:27 +0000
commite0a66c157439fc5512e3406542a5a96667f2e452 (patch)
treedc2d7ae38579af1757a1a0f40dfe31a0450d8b4f /cpukit/libcsupport/Makefile.am
parent2008-01-29 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-e0a66c157439fc5512e3406542a5a96667f2e452.tar.bz2
2008-01-29 Joel Sherrill <joel.sherrill@OARcorp.com>
* libcsupport/Makefile.am, libcsupport/include/rtems/malloc.h, libcsupport/src/malloc_walk.c, libcsupport/src/posix_memalign.c, libcsupport/src/realloc.c, score/src/heapwalk.c: Add rtems_memalign as helper and as exposed nmemalign variant with few restrictions. Also turn on compilation of _Heap_Walk but make forced calls to it conditionally compiled. This should allow more flexibility to the user as to run-time checking of the heap. * libcsupport/src/rtems_memalign.c: New file.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index a36ce089cc..f62c9f96ac 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -79,12 +79,13 @@ ID_C_FILES = src/getegid.c src/geteuid.c src/getgid.c src/getgroups.c \
src/setpgid.c src/setsid.c
MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
- src/realloc.c src/_calloc_r.c src/free.c src/_free_r.c src/_malloc_r.c \
- src/_realloc_r.c src/__brk.c src/__sbrk.c src/mallocfreespace.c \
- src/mallocinfo.c src/malloc_walk.c src/malloc_get_statistics.c \
- src/malloc_report_statistics.c src/malloc_report_statistics_plugin.c \
- src/malloc_statistics_helpers.c src/malloc_boundary.c src/posix_memalign.c \
- src/malloc_deferred.c src/malloc_sbrk_helpers.c src/malloc_dirtier.c
+ src/realloc.c src/_calloc_r.c src/free.c src/_free_r.c src/_malloc_r.c \
+ src/_realloc_r.c src/__brk.c src/__sbrk.c src/mallocfreespace.c \
+ src/mallocinfo.c src/malloc_walk.c src/malloc_get_statistics.c \
+ src/malloc_report_statistics.c src/malloc_report_statistics_plugin.c \
+ src/malloc_statistics_helpers.c src/malloc_boundary.c \
+ src/posix_memalign.c src/rtems_memalign.c src/malloc_deferred.c \
+ src/malloc_sbrk_helpers.c src/malloc_dirtier.c
PASSWORD_GROUP_C_FILES = src/getpwent.c