summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-22 20:16:08 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-22 20:16:08 +0000
commitb6be4217390800fec6a017f7e008957b21361b95 (patch)
tree9c430d377a1754262ccede52c58801e30c1a2b92 /cpukit/libcsupport/Makefile.am
parent2008-05-22 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-b6be4217390800fec6a017f7e008957b21361b95.tar.bz2
2008-05-22 Joel Sherrill <joel.sherrill@oarcorp.com>
* libcsupport/Makefile.am, libcsupport/preinstall.am, libcsupport/include/rtems/termiostypes.h: Move termios helper routines from libchip to libcsupport. Add routine which makes it easy for a termios device driver to inform termios of its default baud rate. This avoids inconsistencies in later termios settings changes.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index d03c0f68e5..72dfdc264f 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -52,7 +52,9 @@ BASE_FS_C_FILES = src/base_fs.c src/mount.c src/unmount.c src/libio.c \
TERMIOS_C_FILES = src/cfgetispeed.c src/cfgetospeed.c src/cfsetispeed.c \
src/cfsetospeed.c src/tcgetattr.c src/tcsetattr.c src/tcdrain.c \
src/tcflow.c src/tcflush.c src/tcgetprgrp.c src/tcsendbreak.c \
- src/tcsetpgrp.c src/termios.c src/termiosinitialize.c
+ src/tcsetpgrp.c src/termios.c src/termiosinitialize.c \
+ src/termios_baud2index.c src/termios_baud2num.c src/termios_num2baud.c \
+ src/termios_setinitialbaud.c
SYSTEM_CALL_C_FILES = src/open.c src/close.c src/read.c src/write.c \
src/write_r.c \