summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-24 21:35:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-24 21:35:10 +0000
commitb5bf8cd163de664f558a5b2b02b01cc8a7722456 (patch)
tree57f78fc92a0ea83967a9b6074bf43c3afa9a5bf2 /cpukit/libcsupport/Makefile.am
parent2007-09-24 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-b5bf8cd163de664f558a5b2b02b01cc8a7722456.tar.bz2
2007-09-24 Joel Sherrill <joel.sherrill@oarcorp.com>
PR 1262/filesystem * libcsupport/Makefile.am, libnetworking/libc/herror.c, libnetworking/libc/res_send.c, libnetworking/sys/uio.h, telnetd/Makefile.am, telnetd/README, telnetd/preinstall.am, telnetd/pty.c, telnetd/telnetd.c: Add support for readv() and writev() including documentation and test case. * libcsupport/src/readv.c, libcsupport/src/writev.c: New files.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index fdbeb48994..10ac75bb31 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -63,6 +63,12 @@ SYSTEM_CALL_C_FILES = src/open.c src/close.c src/read.c src/write.c \
src/pipe.c src/dup.c src/dup2.c src/symlink.c src/readlink.c src/creat.c \
src/chroot.c src/sync.c
+## Until sys/uio.h is moved to libcsupport, we have to have networking
+## enabled to compile these. Hopefully this is a temporary situation.
+if LIBNETWORKING
+SYSTEM_CALL_C_FILES += src/readv.c src/writev.c
+endif
+
DIRECTORY_SCAN_C_FILES = src/opendir.c src/closedir.c src/readdir.c \
src/readdir_r.c src/rewinddir.c src/scandir.c src/seekdir.c \
src/telldir.c src/getcwd.c