summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-04-13 15:15:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-04-13 15:15:28 +0000
commita5777f043d742b107d5aaaf9cb92249c11ae859b (patch)
treee8c83e1a0300b87f122cddf27541643010d819fb /cpukit/libcsupport/Makefile.am
parent2004-04-13 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-a5777f043d742b107d5aaaf9cb92249c11ae859b.tar.bz2
2004-04-13 Ralf Corsepius <ralf_corsepius@rtems.org>
* configure.ac: Rework stdint.h/inttypes.h support. Add RTEMS_USES_STDINT_H. Add RTEMS_USES_INTTYPES_H. Remove NEED_STDINT_H. Remove NEED_INTTYPES_H. Remove termios-flag detection. * libcsupport/Makefile.am: Install include/stdint.h and include/inttypes.h for NEWLIB only. * libcsupport/include/stdint.h: Rework; Now newlib specific. * libcsupport/src/termios.c: Make newlib specific. * include/rtems/stdint.h: Rework; Now wrapper to <stdint.h>.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 1601f18fa8..933c773dcc 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -21,10 +21,9 @@ include_rtems_HEADERS = include/chain.h include/console.h include/clockdrv.h \
include/timerdrv.h include/vmeintr.h
include_HEADERS =
-if NEED_STDINT_H
+
+if NEWLIB
include_HEADERS += include/stdint.h
-endif
-if NEED_INTTYPES_H
include_HEADERS += include/inttypes.h
endif
@@ -177,13 +176,11 @@ $(PROJECT_INCLUDE)/rtems/vmeintr.h: include/vmeintr.h $(PROJECT_INCLUDE)/rtems/$
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/vmeintr.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/vmeintr.h
-if NEED_STDINT_H
+if NEWLIB
$(PROJECT_INCLUDE)/stdint.h: include/stdint.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/stdint.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/stdint.h
-endif
-if NEED_INTTYPES_H
$(PROJECT_INCLUDE)/inttypes.h: include/inttypes.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/inttypes.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/inttypes.h