summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-25 14:58:13 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-25 16:08:16 +0100
commit7e5c9b895e52c76376386e54a0008c3a9e4a1698 (patch)
treebb8f7db25258fc1438c58a60aa950d782d0d77ab /cpukit/libcsupport/Makefile.am
parentsptest/spcache01: New test cases (diff)
downloadrtems-7e5c9b895e52c76376386e54a0008c3a9e4a1698.tar.bz2
rtems: Move rtems_cache_aligned_malloc()
Make sure also the size is cache aligned since otherwise we may have some overlap with the next allocation block. A cache invalidate on this area would be fatal.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index bd3f90a648..95c85c4ede 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -108,6 +108,7 @@ MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
src/rtems_heap_null_extend.c \
src/rtems_heap_extend.c \
src/rtems_heap_greedy.c
+MALLOC_C_FILES += src/cachealignedalloc.c
PASSWORD_GROUP_C_FILES = src/pwdgrp.c
PASSWORD_GROUP_C_FILES += src/getgrent.c