summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-10-27 08:24:50 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-11-08 10:15:28 +0100
commit6de41c5fe9cbfdcc451b7760a0ffa006dcfd8a8e (patch)
tree306defe8ae75aac22fc1c6f785fc8742fd4ca20d /cpukit/libcsupport/Makefile.am
parentbsp/qoriq: Remove duplicate qoriq_gpio definition (diff)
downloadrtems-6de41c5fe9cbfdcc451b7760a0ffa006dcfd8a8e.tar.bz2
Provide kernel space header files
These kernel space header files must be provided for Newlib 172e2050d95b41861db858dd9bc43a3fb4a28987.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 4fea4aa338..bf78fa0c65 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -23,6 +23,11 @@ include_rtems_HEADERS += include/rtems/malloc.h
include_rtems_HEADERS += include/rtems/termiostypes.h
include_rtems_HEADERS += include/rtems/gxx_wrappers.h
+include_machinedir = $(includedir)/machine
+include_machine_HEADERS =
+include_machine_HEADERS += include/machine/_kernel_time.h
+include_machine_HEADERS += include/machine/_kernel_types.h
+
## General stuff
ERROR_C_FILES = src/error.c src/__assert.c