summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-11-18 23:53:14 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-11-18 23:53:14 +0000
commit6c39eca47a9af6de451c65dc43242e29434b5b1f (patch)
tree50e1fe42ae35e05f780becad02a1d9080e686178 /cpukit/libcsupport/Makefile.am
parent2002-11-18 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-6c39eca47a9af6de451c65dc43242e29434b5b1f.tar.bz2
2002-11-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Check for sys/cdefs.h, Add NEED_SYS_CDEFS_H. Add check for CHAR_BIT. * Makefile.am: Conditionally install sys/cdefs.h iff using newlib or if the host does not provide sys/cdefs.h (Fixes Linux/posix).
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 177acf542d..e021c220e8 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -60,6 +60,10 @@ if NEWLIB
NEWLIB_H_FILES = include/sys/termios.h include/sys/utsname.h
endif
+if NEED_SYS_CDEFS_H
+SYS_H_FILES = include/sys/cdefs.h
+endif
+
# FIXME: We should not install to include/sys unless using newlib.
include_sys_HEADERS = \
include/sys/filio.h \
@@ -68,7 +72,7 @@ include/sys/ioctl.h \
include/sys/sockio.h \
include/sys/termios.h \
include/sys/ttycom.h \
-include/sys/cdefs.h \
+$(SYS_H_FILES) \
$(NEWLIB_H_FILES)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \