summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2008-04-11 22:57:54 +0000
committerChris Johns <chrisj@rtems.org>2008-04-11 22:57:54 +0000
commit55c64fc9cd8ddd7a3d4b3207b9c9c698c7a9ec4b (patch)
tree6a00319f7a8793a8dfd64e1732ae7cdff7a82787 /cpukit/libcsupport/Makefile.am
parent2008-04-09 Madhusudan.C.S <madhusudancs@gmail.com> (diff)
downloadrtems-55c64fc9cd8ddd7a3d4b3207b9c9c698c7a9ec4b.tar.bz2
2008-04-12 Chris Johns <chrisj@rtems.org>
* libmisc/shell/shell.c, libmisc/shell/shell.h, libmisc/shell/shell_script.c: Add support to echo the commands to stdout. This is useful with the -v script option to show commands as the run. Also added support to chdir to the directory the task invoking the script is in. * libmisc/shell/extern-cp.h, libmisc/shell/main_cp.c, libmisc/shell/utils-cp.c: Update tro the latest FreeBSD version. * libcsupport/Makefile.am, libcsupport/src/fchown.c: Add fchown support.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index f62c9f96ac..dae118e2cf 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -58,8 +58,8 @@ TERMIOS_C_FILES = src/cfgetispeed.c src/cfgetospeed.c src/cfsetispeed.c \
SYSTEM_CALL_C_FILES = src/open.c src/close.c src/read.c src/write.c \
src/write_r.c \
src/lseek.c src/ioctl.c src/mkdir.c src/mknod.c src/mkfifo.c src/rmdir.c \
- src/chdir.c src/chmod.c src/fchdir.c src/fchmod.c src/chown.c src/link.c \
- src/unlink.c src/umask.c src/ftruncate.c src/utime.c src/fstat.c \
+ src/chdir.c src/chmod.c src/fchdir.c src/fchmod.c src/fchown.c src/chown.c \
+ src/link.c src/unlink.c src/umask.c src/ftruncate.c src/utime.c src/fstat.c \
src/fcntl.c src/fpathconf.c src/getdents.c src/fsync.c src/fdatasync.c \
src/pipe.c src/dup.c src/dup2.c src/symlink.c src/readlink.c src/creat.c \
src/chroot.c src/sync.c src/_rename_r.c