summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-18 20:36:40 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-18 20:36:40 +0000
commit543fe820616f31350366ab61052050303d17dd25 (patch)
treea2e4702be2cd9988ed341586c1c8c976b8ba3bb8 /cpukit/libcsupport/Makefile.am
parent2007-12-18 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-543fe820616f31350366ab61052050303d17dd25.tar.bz2
2007-12-18 Joel Sherrill <joel.sherrill@oarcorp.com>
* libcsupport/Makefile.am, libcsupport/preinstall.am, libcsupport/src/malloc.c, libcsupport/src/mallocinfo.c, libmisc/Makefile.am, libmisc/shell/main_mallocinfo.c, libmisc/shell/shellconfig.h: Split malloc.c into multiple files with one function per file. Also split out statistics into a separate file which can be plugged in dynamically. Right now, it is always in. I suspect that splitting the file removed more code than leaving statistics in. I tinkered with malloc information command in the shell. I resurrected the malloc arena code as malloc boundary. This code is now compiled all the time even though it does not appear to work. * libcsupport/include/rtems/malloc.h, libcsupport/src/_calloc_r.c, libcsupport/src/_free_r.c, libcsupport/src/_malloc_r.c, libcsupport/src/_realloc_r.c, libcsupport/src/calloc.c, libcsupport/src/free.c, libcsupport/src/malloc_boundary.c, libcsupport/src/malloc_get_statistics.c, libcsupport/src/malloc_initialize.c, libcsupport/src/malloc_p.h, libcsupport/src/malloc_report_statistics.c, libcsupport/src/malloc_report_statistics_plugin.c, libcsupport/src/malloc_statistics_helpers.c, libcsupport/src/malloc_walk.c, libcsupport/src/realloc.c, libmisc/shell/main_perioduse.c: New files.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 36aee4bc98..0f54c5c3f9 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -24,7 +24,7 @@ include_rtems_motorola_HEADERS = include/motorola/mc68230.h \
## rtems
include_rtems_HEADERS += include/rtems/assoc.h include/rtems/error.h \
include/rtems/libcsupport.h include/rtems/libio.h include/rtems/libio_.h \
- include/rtems/termiostypes.h
+ include/rtems/malloc.h include/rtems/termiostypes.h
## zilog
@@ -78,8 +78,12 @@ ID_C_FILES = src/getegid.c src/geteuid.c src/getgid.c src/getgroups.c \
src/getlogin.c src/getpgrp.c src/getpid.c src/getppid.c src/getuid.c \
src/setpgid.c src/setsid.c
-MALLOC_C_FILES = src/malloc.c src/mallocfreespace.c src/mallocinfo.c \
- src/__brk.c src/__sbrk.c
+MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
+ src/realloc.c src/_calloc_r.c src/free.c src/_free_r.c src/_malloc_r.c \
+ src/_realloc_r.c src/__brk.c src/__sbrk.c src/mallocfreespace.c \
+ src/mallocinfo.c src/malloc_walk.c src/malloc_get_statistics.c \
+ src/malloc_report_statistics.c src/malloc_report_statistics_plugin.c \
+ src/malloc_statistics_helpers.c src/malloc_boundary.c
PASSWORD_GROUP_C_FILES = src/getpwent.c
@@ -104,7 +108,7 @@ libcsupport_a_SOURCES += $(LIBC_GLUE_C_FILES) $(PASSWORD_GROUP_C_FILES) \
$(TERMIOS_C_FILES) src/getpagesize.c
endif
-EXTRA_DIST = src/TODO src/CASES src/README
+EXTRA_DIST = src/TODO src/CASES src/README src/malloc_p.h
include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am