summaryrefslogtreecommitdiffstats
path: root/cpukit/libcrypt/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-13 15:13:24 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-20 10:30:21 +0100
commit446632197c7f093ed6d0f4d48dcb03e6254828fe (patch)
tree8ff0aa2762bd85492c1926dc74e9ab2dad95b196 /cpukit/libcrypt/Makefile.am
parentAdd SHA256 and SHA512 support (diff)
downloadrtems-446632197c7f093ed6d0f4d48dcb03e6254828fe.tar.bz2
Add crypt_r(), etc.
Add crypt_add_format(), crypt_r(), crypt_md5_r(), crypt_sha256_r() and crypt_sha512_r().
Diffstat (limited to 'cpukit/libcrypt/Makefile.am')
-rw-r--r--cpukit/libcrypt/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/cpukit/libcrypt/Makefile.am b/cpukit/libcrypt/Makefile.am
new file mode 100644
index 0000000000..fe174d4e9d
--- /dev/null
+++ b/cpukit/libcrypt/Makefile.am
@@ -0,0 +1,17 @@
+include $(top_srcdir)/automake/compile.am
+
+include_HEADERS =
+
+noinst_LIBRARIES = libcrypt.a
+
+libcrypt_a_CPPFLAGS = $(AM_CPPFLAGS)
+
+libcrypt_a_SOURCES =
+libcrypt_a_SOURCES += crypt.c
+libcrypt_a_SOURCES += crypt-md5.c
+libcrypt_a_SOURCES += crypt-sha256.c
+libcrypt_a_SOURCES += crypt-sha512.c
+libcrypt_a_SOURCES += misc.c
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/automake/local.am