summaryrefslogtreecommitdiffstats
path: root/cpukit/libblock/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-25 17:01:52 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-25 17:01:52 +0000
commitdbe06865bfc174d2cfe89b7a41f194301fd48aa3 (patch)
tree2be8d009e9a483271dab57bb2b4d1d40badafeac /cpukit/libblock/Makefile.am
parent2003-03-25 Thomas Doerfler <Thomas.Doerfler@imd-systems.de> (diff)
downloadrtems-dbe06865bfc174d2cfe89b7a41f194301fd48aa3.tar.bz2
2003-03-25 Thomas Doerfler <Thomas.Doerfler@imd-systems.de>
PR 367/filesystem * Makefile.am, include/rtems/ide_part_table.h, src/ata.c, src/ide_part_table.c: Some bugs were still present in the DOSFS implementation: - FAT12 did not work properly on Big-Endian machines - Some synchronization and error handling problems were present - Some legal codings for EOC were not recognized
Diffstat (limited to 'cpukit/libblock/Makefile.am')
-rw-r--r--cpukit/libblock/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/cpukit/libblock/Makefile.am b/cpukit/libblock/Makefile.am
index 23c71db437..c8f5e949d4 100644
--- a/cpukit/libblock/Makefile.am
+++ b/cpukit/libblock/Makefile.am
@@ -18,14 +18,18 @@ $(PROJECT_INCLUDE)/rtems:
include_rtems_HEADERS = \
include/rtems/bdbuf.h include/rtems/blkdev.h \
- include/rtems/diskdevs.h include/rtems/ramdisk.h
+ include/rtems/diskdevs.h include/rtems/ramdisk.h \
+ include/rtems/ata.h include/rtems/ata_internal.h \
+ include/rtems/ide_part_table.h
PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
$(include_rtems_HEADERS:include/%=$(PROJECT_INCLUDE)/%)
LIB = ${ARCH}/libblock.a
-C_FILES = src/bdbuf.c src/blkdev.c src/diskdevs.c src/ramdisk.c
+C_FILES = src/bdbuf.c src/blkdev.c src/diskdevs.c src/ramdisk.c\
+ src/ata.c src/ide_part_table.c
+
OBJS = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))
AM_CFLAGS += $(LIBC_DEFINES)