summaryrefslogtreecommitdiffstats
path: root/cpukit/libblock/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-31 05:48:15 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-31 05:48:15 +0000
commitc3214961812b760bf86b20b16afcae91037164bb (patch)
tree6a556682c8a3ab09aa138a8a3b48147d6333e725 /cpukit/libblock/Makefile.am
parent2002-07-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-c3214961812b760bf86b20b16afcae91037164bb.tar.bz2
2002-07-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge src/Makefile.am. * src/Makefile.am: Remove. * configure.ac: Remove src/Makefile.am
Diffstat (limited to 'cpukit/libblock/Makefile.am')
-rw-r--r--cpukit/libblock/Makefile.am24
1 files changed, 20 insertions, 4 deletions
diff --git a/cpukit/libblock/Makefile.am b/cpukit/libblock/Makefile.am
index cbae75e203..22565e5b47 100644
--- a/cpukit/libblock/Makefile.am
+++ b/cpukit/libblock/Makefile.am
@@ -4,7 +4,9 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-SUBDIRS = src
+include $(top_srcdir)/../automake/multilib.am
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/lib.am
include_rtemsdir = $(includedir)/rtems
@@ -21,9 +23,23 @@ include_rtems_HEADERS = \
PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
$(include_rtems_HEADERS:include/%=$(PROJECT_INCLUDE)/%)
-all-local: $(PREINSTALL_FILES)
+LIB = ${ARCH}/libblock.a
-EXTRA_DIST = README
+C_FILES = src/bdbuf.c src/blkdev.c src/diskdevs.c src/ramdisk.c
+
+C_O_FILES = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))
+
+SRCS = $(C_FILES)
+OBJS = $(C_O_FILES)
+
+AM_CFLAGS += $(LIBC_DEFINES)
+
+${ARCH}/%.$(OBJEXT): src/%.c
+ ${COMPILE} -o $@ -c $<
+
+$(LIB): ${OBJS}
+ $(make-library)
+
+all-local: $(PREINSTALL_FILES) ${ARCH} $(LIB)
-include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/local.am