summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-09 18:22:16 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-09 18:22:16 +0000
commitb71e8d050a743b620feee38315af7f605cb8f463 (patch)
treec333513b919d88666d0b5030bc9838e398d35228 /cpukit/itron/Makefile.am
parent2004-01-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-b71e8d050a743b620feee38315af7f605cb8f463.tar.bz2
2004-01-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add libs to CLEANFILES Set lib*_g_a_SOURCES = lib*_a_SOURCES.
Diffstat (limited to 'cpukit/itron/Makefile.am')
-rw-r--r--cpukit/itron/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/cpukit/itron/Makefile.am b/cpukit/itron/Makefile.am
index 1188d8edc5..2c32b25a23 100644
--- a/cpukit/itron/Makefile.am
+++ b/cpukit/itron/Makefile.am
@@ -105,21 +105,23 @@ AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
EXTRA_LIBRARIES = libitron.a
+CLEANFILES = libitron.a
libitron_a_SOURCES = $(C_FILES)
libitron_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
EXTRA_LIBRARIES += libitron_g.a
-libitron_g_a_SOURCES = $(C_FILES)
+CLEANFILES += libitron_g.a
+libitron_g_a_SOURCES = $(libitron_a_SOURCES)
libitron_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
all-local: $(PREINSTALL_FILES) libitron$(LIB_VARIANT).a
endif
UNUSED_C_FILES = src/cre_mbx.c src/del_mbx.c src/mboxtranslatereturncode.c \
- src/network.c src/prcv_mbx.c src/rcv_mbx.c src/ref_mbx.c src/snd_mbx.c \
- src/sysmgmt.c src/trcv_mbx.c
+ $(NETWORK_C_FILES) src/prcv_mbx.c src/rcv_mbx.c src/ref_mbx.c \
+ src/snd_mbx.c $(CONFIGURATION_C_FILES) src/trcv_mbx.c
-EXTRA_DIST += $(C_FILES) $(UNUSED_C_FILES) src/TODO
+EXTRA_DIST += $(UNUSED_C_FILES) src/TODO
PREINSTALL_FILES =