summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 05:21:56 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-14 05:21:56 +0000
commit8a2c17969e843607123e63b34fcae7896c419c55 (patch)
tree58c8e5e5a0207fc7d2b5ef6642b99ad035770f54 /cpukit/itron/Makefile.am
parent2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8a2c17969e843607123e63b34fcae7896c419c55.tar.bz2
2004-01-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Re-add dirstamps to PREINSTALL_FILES. Add PREINSTALL_FILES to CLEANFILES.
Diffstat (limited to 'cpukit/itron/Makefile.am')
-rw-r--r--cpukit/itron/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/cpukit/itron/Makefile.am b/cpukit/itron/Makefile.am
index bc8828bc20..df69b06c16 100644
--- a/cpukit/itron/Makefile.am
+++ b/cpukit/itron/Makefile.am
@@ -6,6 +6,7 @@ include $(top_srcdir)/automake/multilib.am
include $(top_srcdir)/automake/compile.am
EXTRA_DIST =
+CLEANFILES =
if HAS_ITRON
## include
@@ -105,7 +106,7 @@ AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
EXTRA_LIBRARIES = libitron.a
-CLEANFILES = libitron.a
+CLEANFILES += libitron.a
libitron_a_SOURCES = $(C_FILES)
libitron_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
@@ -128,6 +129,7 @@ PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
if HAS_ITRON
$(PROJECT_INCLUDE)/itron.h: include/itron.h $(PROJECT_INCLUDE)/$(dirstamp)
@@ -137,6 +139,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/itron.h
$(PROJECT_INCLUDE)/itronsys/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/itronsys
@: > $(PROJECT_INCLUDE)/itronsys/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/itronsys/$(dirstamp)
$(PROJECT_INCLUDE)/itronsys/eventflags.h: include/itronsys/eventflags.h $(PROJECT_INCLUDE)/itronsys/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/itronsys/eventflags.h
@@ -197,6 +200,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/itronsys/vmempool.h
$(PROJECT_INCLUDE)/rtems/itron/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/itron
@: > $(PROJECT_INCLUDE)/rtems/itron/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/itron/config.h: include/rtems/itron/config.h $(PROJECT_INCLUDE)/rtems/itron/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/itron/config.h
@@ -358,4 +362,6 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron/vmempool.inl
endif
endif
+CLEANFILES += $(PREINSTALL_FILES)
+
include $(top_srcdir)/automake/local.am